Leaps 3.0 requires that you run the latest version of Adobe Flash Player which is not currently installed on your computer.
To get the latest version of Adobe Reader, click here, to download and install.
Once you have completed this installation, please log into Leaps 3.0 again.